Lists: | pgsql-committers |
---|
From: | Nathan Bossart <nathan(at)postgresql(dot)org> |
---|---|
To: | pgsql-committers(at)lists(dot)postgresql(dot)org |
Subject: | pgsql: Improve the naming in wal_sync_method code. |
Date: | 2023-10-13 20:17:55 |
Message-ID: | E1qrOba-000P08-NA@gemulon.postgresql.org |
Views: | Raw Message | Whole Thread | Download mbox | Resend email |
Lists: | pgsql-committers |
Improve the naming in wal_sync_method code.
* sync_method is renamed to wal_sync_method.
* sync_method_options[] is renamed to wal_sync_method_options[].
* assign_xlog_sync_method() is renamed to assign_wal_sync_method().
* The names of the available synchronization methods are now
prefixed with "WAL_SYNC_METHOD_" and have been moved into a
WalSyncMethod enum.
* PLATFORM_DEFAULT_SYNC_METHOD is renamed to
PLATFORM_DEFAULT_WAL_SYNC_METHOD, and DEFAULT_SYNC_METHOD is
renamed to DEFAULT_WAL_SYNC_METHOD.
These more descriptive names help distinguish the code for
wal_sync_method from the code for DataDirSyncMethod (e.g., the
recovery_init_sync_method configuration parameter and the
--sync-method option provided by several frontend utilities). This
change also prevents name collisions between the aforementioned
sets of code. Since this only improves the naming of internal
identifiers, there should be no behavior change.
Author: Maxim Orlov
Discussion: https://postgr.es/m/CACG%3DezbL1gwE7_K7sr9uqaCGkWhmvRTcTEnm3%2BX1xsRNwbXULQ%40mail.gmail.com
Branch
------
master
Details
-------
https://git.postgresql.org/pg/commitdiff/8d140c58229d6224882f881d9b62ba06236e71d3
Modified Files
--------------
src/backend/access/transam/xlog.c | 58 ++++++++++++++++++-------------------
src/backend/storage/file/fd.c | 4 +--
src/backend/utils/misc/guc_tables.c | 8 ++---
src/include/access/xlog.h | 15 ++++++----
src/include/access/xlogdefs.h | 8 ++---
src/include/port/freebsd.h | 2 +-
src/include/port/linux.h | 2 +-
src/include/utils/guc_hooks.h | 2 +-
src/tools/pgindent/typedefs.list | 1 +
9 files changed, 52 insertions(+), 48 deletions(-)