FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.
FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.
Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
Input
There are several test cases. Each test case consists of
a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.
Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
Sample Input
3 1 1 2 5 10 11 6 12 12 7 -1 -1
Sample Output
37
说起记忆化搜索,我的理解是他和dfs几乎一样,就是多了一个用dp【】数组存储每一步最优解的过程。这样的话每计算一个新位置dp【i】的最优解时,直接套用dp【i-1】进行某种运算即可得到dp【i】了。这大大简化了dfs的运算过程,从而减少运算时间。
这道题说的是:在一个n阶方阵A中,Aij表示在第i行第j列的位置处所有的cheese数目。老鼠起始位置为(0,0),老鼠在方阵中移动的规则是:
<1>、每次最多沿着水平(或垂直)方向跳k格;
<2>、每次所跳至的格中cheese数目要比当前位置处得多。
求老鼠所能得到的cheese的最大数目。
AC代码:
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define maxn 1005
int a[maxn][maxn];
int dp[maxn][maxn];
int n,k;
int dir[4][2]={0,1,0,-1,1,0,-1,0};
int dfs(int x,int y)
{
if(!dp[x][y])
{
int ans=0;
for(int zz=1;zz<=k;zz++)
{
for(int i=0;i<4;i++)
{
int xx=x+dir[i][0]*zz;
int yy=y+dir[i][1]*zz;
if(xx>=0&&xx<n&&yy>=0&&yy<n&&a[xx][yy]>a[x][y])
{
ans=max(ans,dfs(xx,yy));
}
}
}
dp[x][y]=ans+a[x][y];
}
return dp[x][y];
}
int main()
{
while(scanf("%d%d",&n,&k)&&(n!=-1||k!=-1))
{
memset(dp,0,sizeof(dp));
memset(a,0,sizeof(a));
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
scanf("%d",&a[i][j]);
}
printf("%d\n",dfs(0,0));
}
return 0;
}