F - Large Division(大数取模模板)

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

模板体,没有技术含量,在此记录一下,以便复习。

AC代码如下:

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<string>
#include<math.h>
#include<map>
#include<vector>
#include<set>
#include<iostream>
using namespace std;
typedef long long ll;
int main()
{
	int n,i;
	ll ans,b;
	char a[700];
	scanf("%d",&n);
	int k=1;
	while(n--)
	{
		scanf("%s%lld",a,&b);
		ans=0;
		if(b<0)	b=-1*b;
		for(i=0;i<strlen(a);i++)
		{
			if(a[0]=='-')	a[i]='0';
			ans=(ans*10+(a[i]-'0'))%b;
		}
		if(ans==0)
			printf("Case %d: divisible\n",k++);
		else
			printf("Case %d: not divisible\n",k++);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小小的香辛料

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值