CodeForces 959-B Mahmoud and Ehab and the message(map)

博客围绕消息发送成本问题展开,一个人给朋友发消息,每个词有发送成本,存在一些同义词语可替换。需根据输入的词数量、同义组数量、消息词数量等信息,计算出消息发送的最低成本,并给出了示例及代码思路。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Description

Mahmoud wants to send a message to his friend Ehab. Their language consists of n words numbered from 1 to n. Some words have the same meaning so there are k groups of words such that all the words in some group have the same meaning.

Mahmoud knows that the i-th word can be sent with cost ai. For each word in his message, Mahmoud can either replace it with another word of the same meaning or leave it as it is. Can you help Mahmoud determine the minimum cost of sending the message?

The cost of sending the message is the sum of the costs of sending every word in it.

 

Input 

The first line of input contains integers n, k and m (1 ≤ k ≤ n ≤ 105, 1 ≤ m ≤ 105) — the number of words in their language, the number of groups of words, and the number of words in Mahmoud's message respectively.

The second line contains n strings consisting of lowercase English letters of length not exceeding 20 which represent the words. It's guaranteed that the words are distinct.

The third line contains n integers a1, a2, ..., an (1 ≤ ai ≤ 109) where ai is the cost of sending the i-th word.

The next k lines describe the groups of words of same meaning. The next k lines each start with an integer x (1 ≤ x ≤ n) which means that there are x words in this group, followed by xintegers which represent the indices of words in this group. It's guaranteed that each word appears in exactly one group.

The next line contains m space-separated words which represent Mahmoud's message. Each of these words appears in the list of language's words.

 

Output 

The only line should contain the minimum cost to send the message after replacing some words (maybe none) with some words of the same meaning.

 

Sample Input     

5 4 4
i loser am the second
100 1 1 5 10
1 1
1 3
2 2 5
1 4
i am the second

 

Sample Output     

107

 

 Sample Input     

5 4 4
i loser am the second
100 20 1 5 10
1 1
1 3
2 2 5
1 4
i am the second

 

 Sample Output     

116

 

Note 

In the first sample, Mahmoud should replace the word "second" with the word "loser" because it has less cost so the cost will be 100+1+5+1=107.

In the second sample, Mahmoud shouldn't do any replacement so the cost will be 100+1+5+10=116.

 

题意:

一个人给另一个人发消息,其中发的消息里面的信息,每一个信息都有对应发送的成本。
这个想发送的成本最低。输出最低的成本。代表输入n个已知的信息,下面一行对应每个信息的价值。然后是k行,每一行第一个就代表有x个可以互相替换的信息的下标。
1个 表示无法替换,2 2 5代表有两个可以互相替换的信息的下标。最后一行m个需要发送的信息。

 

代码:

#include<cstdio>
#include<iostream>
#include<map>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1e5 + 10;
int cost[maxn];
int c[maxn];

int main(){
	memset(c, 0x7f, sizeof(c));
	int n, m, k;
	long long ans = 0;
	cin >> n >> k >> m;
	string a[maxn], b;
	for(int i = 1; i <= n; i++) cin >> a[i];
	for(int i = 1; i <= n; i++) cin >> cost[i];
	map<string, int> s;
	for(int i = 1; i <= k; i++){
		int d;
		scanf("%d", &d);
		while(d--){
			int pos;
			scanf("%d", &pos);
			s.insert(make_pair(a[pos], i));
			c[i] = min(c[i], cost[pos]);
		}
	}
	map<string, int>::iterator iter;
	for(int i = 1; i <= m; i++){
		cin >> b;
		iter = s.find(b);
		ans += c[iter->second];
	}
	cout << ans;
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值