Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
Sample Input
clinton homer riemann marjorie
Sample Output
0 rie 3
题意:
给定两个串S1和S2,你要找到S1的最长前缀,且这个前缀还要是S2的后缀.
思路:
利用KMP计算串S2的后缀能匹配S1的前缀是多长。即让S2作为待匹配串,S1作为模板串。然后用S1去匹配S2,看看S2中i位置能匹配S1串最长前缀的长度ex[i]。
代码:
#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
const int MAXN=50000+1000;
char T[MAXN],P[MAXN];
int f[MAXN],ex[MAXN];
int n,m;
void getFail()
{
f[0]=f[1]=0;
for(int i=1;i<m;i++)
{
int j=f[i];
while(j && P[i]!=P[j]) j=f[j];
f[i+1] = (P[i]==P[j])?j+1:0;
}
}
void find()
{
int j=0;
for(int i=0;i<n;i++)
{
while(j && T[i]!=P[j]) j=f[j];
if(T[i]==P[j])j++;
ex[i]=j;//在用KMP计算两字符串前缀后缀的时候常用到,j为两串相同的长度,i为在T串中出现的位置
//if(j==m)//j为两串相同的长度,i为在T串中出现的位置
//{
//cnt++;
//printf("%d\n", i - m + 1);//输出每次P串在T串中每一次出现的位置,注意下标是从0开始的
//return i-m+1; (前面要变成 int find函数)
//}
}
}
int main()
{
while(scanf("%s %s",P,T)==2)
{
n=strlen(T);
m=strlen(P);
getFail();
find();
if(ex[n-1]==0)
printf("0\n");
else
{
for(int i=0;i<ex[n-1];i++)
printf("%c",P[i]);
printf(" %d\n",ex[n-1]);
}
}
return 0;
}