一、网络拓扑说明
本 WLAN 网络由交换机(LSW2)、无线控制器(AC2)、无线接入点(AP3\4)以及无线客户端(STA1)组成。其中,划分了业务 VLAN(vlan200,网段 192.168.200.1/24)和管理 VLAN(vlan100,网段 192.168.100.1/24) 。
二、设备配置
二、设备配置
(一)交换机(LSW2)配置
# 创建管理VLAN 100和业务VLAN 200
vlan batch 100 200
quit
# 配置GE0/0/1接口(连接AC2)
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 100 200
quit
# 配置GE0/0/2接口(连接AP3)
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 100
port trunk pvid vlan 100
quit
# 配置GE0/0/3接口(连接AP4)
interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 100
port trunk pvid vlan 100
quit
# 配置vlan接口地址,并配置地址池
interface vlan 100
ip add 192.168.100.1 24
dhcp select in
dhcp server ex 192.168.100.100
interface vlan 200
ip add 192.168.200.1 24
dhcp select in
(二)无线控制器(AC2)配置
# 创建管理VLAN 100和业务VLAN 200
vlan batch 100 200
quit
# 配置Vlanif10接口(管理VLAN网关)
interface Vlanif100
ip address 192.168.100.100 24
quit
# 配置缺省路由指向核心交换机
ip route-static 0.0.0.0 0 192.168.100.1
# 配置GE0/0/1接口(连接交换机)
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 100 200
quit
# 配置源接口
capwap source interface Vlanif100
# 配置交换机上线
wlan
ap auth-mode no-auth(修改为不认证)
quit
等待AP上线
# 配置业务模块
wlan
regulatory-domain-profile name office
country-code cn
quit
# 配置SSID模板
ssid-profile name office
ssid office
quit
# 配置安全模板
security-profile name office
security wpa2 psk pass-phrase office123 aes
# 创建业务VAP模板
vap-profile name office
ssid-profile office
security-profile office
service-vlan vlan-id 200
forward-mode tunnel
# 绑定业务VAP模板到AP组并关联业务VLAN 200
ap-group name default
regulatory-domain-profile office
vap-profile office wlan 1 radio all
quit