1072. Gas Station (30)

本文介绍了一个基于图论的算法,用于解决城市中加油站的最佳选址问题。该算法确保所有住宅都在加油站的服务范围内,并且尽可能地使最远住宅的距离最小化。在存在多个解决方案的情况下,选择平均距离最小且编号最小的加油站位置。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 103), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 104), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format
P1 P2 Dist
where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

Sample Input 1:
4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2
Sample Output 1:
G1
2.0 3.3
Sample Input 2:
2 1 2 10
1 G1 9
2 G1 20
Sample Output 2:
No Solution
这道题目读懂就够费劲了,英语不好真的很伤,意思是首先你所有居民房都要在建设加油点服务范围Ds以内,如果有多种情况,则需要最近的一个房子距离比较远的方案,
如果也有相同则需要考虑所有房子总距离最小的方案,再者就是标号较小的建设点;
用的dijkstra,其实有时候挺纠结用dfs还是迪杰斯特拉,这道题目一开始用dfs尝试了下发现问题还挺多的,因为dfs只搜索一遍的话只是简单的遍历并不能得出最短路径,
还不是很熟练

#include <iostream>
#include <cctype>
#include <vector>
#include <utility>
#include <cstring>
#include <iterator>
#include <cstdio>
#include <iomanip>
#define MAX 1015
#define INF (0x6fffffff)
using namespace std;

struct Node{
    bool known;
    vector<pair<int, int> > v;
};

Node graph[MAX] = {false};
int dist[MAX] = {0};
int N, M, K, Ds;
void init()
{
    int w;
    int v1, v2;
    char vertex1[10], vertex2[10];
    for(int i=0; i<K; i++)
    {
        cin >> vertex1 >> vertex2 >> w;
        if(isdigit(vertex1[0]))
        {
            sscanf(vertex1, "%d", &v1);
        }
        else
        {
            sscanf(&vertex1[1], "%d", &v1);
            v1 += N;
        }
        if(isdigit(vertex2[0]))
        {
            sscanf(vertex2, "%d", &v2);
        }
        else
        {
            sscanf(&vertex2[1], "%d", &v2);
            v2 += N;
        }
        graph[v1].v.push_back(make_pair(v2, w));
        graph[v2].v.push_back(make_pair(v1, w));
    }
}
void dijkstra(int n)
{
    dist[n] = 0;
    int mindist, key;
    int temp = N+M;
    vector<pair<int, int> >::iterator it;
    while(temp--)
    {
        mindist = INF;
        for(int i=1; i<=N+M; i++)
        {
            if(dist[i] < mindist && !graph[i].known)
            {
                mindist = dist[i];
                key = i;
            }
        }
        graph[key].known = true;
        for(it=graph[key].v.begin(); it!=graph[key].v.end(); it++)
        {
            if(!graph[it->first].known)
            {
                if(it->second+mindist < dist[it->first])
                {
                    dist[it->first] = it->second+mindist;
                }
            }
        }
    }
}

int main()
{
    int k, ans, mind = -1;
    int finalsum = INF;
   // freopen("in.txt", "r", stdin);
    cin >> N >> M >> K >> Ds;
    init();
    for(int i=N+1; i<=N+M; i++)
    {
        for(int j=1; j<=N+M; j++)
        {
            dist[j] = INF;
            graph[j].known = false;
        }
        dijkstra(i);
        int sum = 0;
        int mindist = INF;
        for(k=1; k<=N; k++)
        {
            sum += dist[k];
            if(mindist > dist[k])
                mindist = dist[k];
            if(dist[k] > Ds)
            {
                break;
            }
        }
        if(k == N+1)
        {
            if(mindist > mind)
            {
                mind = mindist;
                ans = i;
                finalsum = sum;
            }
            else if(mindist == mind)
            {
                if(sum < finalsum)
                {
                    finalsum = sum;
                    ans = i;
                }
            }
        }
    }
    if(mind == -1)
    {
        cout << "No Solution" << endl;
    }
    else{
        cout << "G" << ans-N << endl;
        cout << fixed << setprecision(1) << mind*1.0 << " " << finalsum*1.0/N << endl;
    }
    return 0;

}


### 高德地图日志输出的意义 在 Android 开发过程中,当集成高德地图功能时,可能会遇到特定的日志输出。以下是针对 `GasStation` 和 `高德地图客户端已经安装` 这两类日志的具体解释。 #### 关于 'GasStation' 如果在调试或运行应用期间发现日志中有 `'GasStation'` 输出,则可能表示当前的地图操作涉及到了加油站的相关数据点。这通常发生在以下场景中: - 地图上加载了 POI(兴趣点)数据,而这些数据包含了加油站的信息。 - 应用正在查询与加油站点有关的服务或者路径规划[^1]。 这种日志可能是由高德地图 SDK 自动记录的行为,用于指示某些特定类型的地理特征被处理或展示给用户。它并不一定代表错误或警告;相反,它是正常工作流程的一部分,表明 SDK 正确解析并呈现了相关位置信息。 #### 关于 '高德地图客户端已经安装' 此条目明确指出设备上存在官方发布的高德地图应用程序实例。这一确认过程通常是通过检查目标软件包名来完成的——对于高德而言,默认情况下其主包名称为 `com.autonavi.minimap` 或其他变体形式[^2]。一旦检测到对应的应用存在于用户的移动终端里,便会触发上述消息打印至控制台作为反馈机制之一: ```java public static boolean isGaoDeMapInstalled(Context context){ try { ApplicationInfo info = context.getPackageManager() .getApplicationInfo("com.autonavi.minimap", PackageManager.GET_META_DATA); return true; } catch (PackageManager.NameNotFoundException e) { return false; } } ``` 这段伪代码展示了如何利用 Android 提供的标准 API 来验证指定 APP 是否可用,并据此调整后续逻辑走向比如决定采用嵌入式视图还是跳转外部链接等形式提供服务[^3]。 综上所述,“高德地图客户端已经安装”的提示有助于开发者了解环境状态从而做出更优决策同时也让用户获得更好的体验效果。 ```java if(isGaoDeMapInstalled(context)){ Log.d("MAP_STATUS","高德地图客户端已经安装"); } else{ Toast.makeText(context,"请先下载安装高德地图!",Toast.LENGTH_SHORT).show(); } ``` 以上示例简单演示了基于前面提到方法的结果来进行基本交互设计的一种方式。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值