1037. Magic Coupon (25)

在火星一家魔法商店中,顾客可以通过使用特定数值的魔法优惠券来获取商品价值的倍数返还,但若用于免费赠品则需支付相应费用。本篇介绍了一种算法,通过合理搭配优惠券和商品来最大化顾客的收益。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;
typedef long long ll;

bool cmp(const ll &a, const ll &b)
{
    return a > b;
}
int main()
{
    int n, m;
    ll temp;
    vector<ll> v1, v2;
    cin >> n;
    for(int i=0; i<n; i++)
    {
        cin >> temp;
        v1.push_back(temp);
    }
    cin >> m;
    for(int i=0; i<m; i++)
    {
        cin >> temp;
        v2.push_back(temp);
    }
    sort(v1.begin(), v1.end(), cmp);
    sort(v2.begin(), v2.end(), cmp);
    int i, j, k;
    ll total = 0;
    for(i=0; v1[i]>0 && v2[i]>0; i++)
    {
        total += v1[i]*v2[i];
    }
    for(j=n-1, k=m-1; v1[j]<0 && v2[k]<0; j--, k--)
    {
        total += v1[j]*v2[k];
    }
    cout << total << endl;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值