1030. Travel Plan (30)

本文介绍了一个基于Dijkstra算法实现的程序,该程序能够帮助旅行者找到从起点到终点之间的最短路径及最小成本路径。输入包括城市数量、高速公路数量、起点和终点等信息,通过邻接矩阵存储每条高速公路的距离和成本。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40
最基本的求最短路径,用的是dijkstra算法

#include <iostream>
#include <vector>
#include <utility>
#include <cstring>
#define MAX 505
#define INF (1<<30)
using namespace std;


bool visit[MAX] = {false};
int pre[MAX];
int dist[MAX];
int mincost[MAX] = {0};
int N, M, S, D;
pair<int, int> city[MAX][MAX];//pair型邻接矩阵first记录路长second记录路费

void graph_init()
{
    int v, w, dis, cost;
    memset(pre, -1, sizeof(int)*N);
    for(int i=0; i<N; i++)
    {
        dist[i] = INF;
        for(int j=0; j<N; j++)
            city[i][j] = make_pair(INF, INF);
    }
    for(int i=0; i<M; i++)
    {
        cin >> v >> w >> dis >> cost;
        city[v][w] = make_pair(dis, cost);
        city[w][v] = make_pair(dis, cost);
    }
}

void dijkstra()
{
    int mindist;
    int key;
    dist[S] = 0;
    for(int i=0; i<N; i++)
    {
        mindist = INF;
        for(int j=0; j<N; j++)
        {
            if(mindist > dist[j] && !visit[j])
            {
                mindist = dist[j];
                key = j;
            }
        }
        if(key == D)
            break;
        visit[key] = true;
        for(int j=0; j<N; j++)
        {
            if(!visit[j])
            {
                if(city[key][j].first+mindist < dist[j])
                {
                    dist[j] = city[key][j].first+mindist;
                    mincost[j] = mincost[key]+city[key][j].second;
                    pre[j] = key;
                }
                else if(city[key][j].first+mindist == dist[j])//路径相同时计算哪条路径路费较小
                {
                    if(mincost[j] > mincost[key]+city[key][j].second)
                    {
                        pre[j] = key;
                        mincost[j] = mincost[key]+city[key][j].second;
                    }
                }
            }
        }
    }
}

void print_path(int x)
{
    if(pre[x] != -1)
        print_path(pre[x]);
    cout << x << " ";
}
int main()
{
    cin >> N >> M >> S >> D;
    graph_init();
    dijkstra();
    print_path(D);
    cout << dist[D] << " " << mincost[D] << endl;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值