1017. Queueing at Bank (25)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2


思路:对每位顾客一次处理,如果他来的比当前最早处理完的窗口时间还要早,那么计算他的等待时间,并且他的结束时间是最早处理完的时间加上他的处理时间,结束时间进入优先队列,如果来的晚那么可以直接开始,等待时间就为0;结束时间就是来的时间加上处理时间

#include <iostream>
#include <queue>
#include <algorithm>
#include <functional>
#include <vector>
#include <cstdio>
#define MAX 10005

using namespace std;

struct cust{
    int time;
    int cost;
}c[MAX];

bool cmp(const cust &a, const cust &b)
{
    return a.time < b.time;
}
int main()
{
    const int Start = 8*3600;
    const int End = 17*3600;
    int hh, mm, ss;
    int time, cost, totalwait, counter;
    int endtime;
    int n, k;
    priority_queue<int, vector<int>, greater<int> > windows;//优先队列,按处理时间完毕先后表示优先级,先处理完的放在顶端
    cin >> n >> k;
    for(int i=0; i<n; i++)
    {
        scanf("%d:%d:%d %d", &hh, &mm, &ss, &cost);
        time = hh*3600+mm*60+ss;
        c[i].time = time;
        c[i].cost = cost;
    }
    sort(c, c+n, cmp);
    totalwait = 0;
    counter = 0;
    for(int i=0; i<k; i++)//第一批人
    {
        if(c[counter].time < End)
        {
            if(c[counter].time < Start)//如果来的比8点还早那么需要等待
            {
                totalwait += Start-c[counter].time;//等待时间
                endtime = Start+c[counter].cost*60;//处理完的时间
            }
            else{
                endtime = c[counter].time+c[counter].cost*60;//比8点完则不需要等待
            }
            windows.push(endtime);
            counter++;
        }
    }
    for(int i=counter; i<n; i++)
    {
        if(c[counter].time > End)//如果顾客到达时间晚于结束时间则break掉
            break;
        if(windows.size() == k)
        {
            if(windows.top() <= c[counter].time)//当最早处理完的时间不大于下一位顾客到的时间,无需等待
            {
                windows.pop();
                endtime = c[counter].time+c[counter].cost*60;
                windows.push(endtime);
                counter++;
            }
            else{//否则则计算等待时间
                totalwait += windows.top() - c[counter].time;
                endtime = windows.top() + c[counter].cost*60;
                windows.pop();
                windows.push(endtime);
                counter++;
            }
        }
    }
    printf("%.1f\n", 1.0*totalwait/counter/60);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值