1021. Deepest Root (25)

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.

Sample Input 1:
5
1 2
1 3
1 4
2 5
Sample Output 1:
3
4
5
Sample Input 2:
5
1 3
1 4
2 5
3 4
Sample Output 2:
Error: 2 components
对每个点用BFS求出他的最长路径,效率很低不过还是过了,网上还有2次DFS就可以得出结果,还没有仔细看过,有时间再研究一下

/***并查集求集合数量***/
/****BFS求最长路径***/
#include <iostream>
#include <vector>
#include <queue>
#include <utility>
#include <cstring>
#define MAX 10005
using namespace std;

vector<int> graph[MAX];
bool visit[MAX];
int maxlen[MAX];//记录每个点最大深度
int pre[MAX] = {0};
int maxh = 0;//记录最大深度

int Find(int x)
{
    return pre[x]==x ? x : pre[x]=Find(pre[x]);
}

void Union(int x, int y)
{
    int u = Find(x);
    int v = Find(y);
    if(u == v)
        return ;
    pre[u] = v;
}

int bfs(int x)
{
    int len = 0;
    int dist[MAX] = {0};
    queue<int> myque;
    myque.push(x);
    visit[x] = true;
    while(!myque.empty())
    {
        x = myque.front();
        myque.pop();
        visit[x] = true;
        for(vector<int>::size_type i=0; i<graph[x].size(); i++)
        {
            if(!visit[graph[x][i]])
            {
                dist[graph[x][i]] = dist[x]+1;
                if(len < dist[graph[x][i]])
                    len = dist[graph[x][i]];
                myque.push(graph[x][i]);
            }
        }
    }
    if(len > maxh)
        maxh = len;
    return len;
}
int main()
{
    int n, x, y;
    int maxl = -1;
    int counter = 0;
    cin >> n;
    for(int i=0; i<=n; i++)
        pre[i] = i;
    for(int i=0; i<n-1; i++)
    {
        cin >> x >> y;
        graph[x].push_back(y);
        graph[y].push_back(x);
        Union(x, y);
    }
    for(int i=1; i<=n; i++)
    {
        if(pre[i] == i)
            counter++;
    }
    if(counter > 1)
        cout << "Error: " << counter <<" components" << endl;
    else
    {
        for(int i=1; i<=n; i++)
        {
            memset(visit, false, sizeof(bool)*(n+1));
            maxlen[i] = bfs(i);
        }
        for(int i=1; i<=n; i++)
        {
            if(maxlen[i] == maxh)
                cout << i << endl;
        }
    }
    return 0;
}

# -*- coding: utf-8 -*- '''请在Begin-End之间补充代码, 完成BinaryTree类''' class BinaryTree: # 创建左右子树为空的根结点 def __init__(self, rootObj): self.key = rootObj # 成员key保存根结点数据项 self.leftChild = None # 成员leftChild初始化为空 self.rightChild = None # 成员rightChild初始化为空 # 把newNode插入到根的左子树 def insertLeft(self, newNode): if self.leftChild is None: self.leftChild = BinaryTree(newNode) # 左子树指向由newNode所生成的BinaryTree else: t = BinaryTree(newNode) # 创建一个BinaryTree类型的新结点t t.leftChild = self.leftChild # 新结点的左子树指向原来根的左子树 self.leftChild = t # 根结点的左子树指向结点t # 把newNode插入到根的右子树 def insertRight(self, newNode): if self.rightChild is None: # 右子树指向由newNode所生成的BinaryTree # ********** Begin ********** # self.rightChild = BinaryTree(newNode) # ********** End ********** # else: t = BinaryTree(newNode) t.rightChild = self.rightChild self.rightChild = t # ********** End ********** # # 取得右子树,返回值是一个BinaryTree类型的对象 def getRightChild(self): # ********** Begin ********** # return self.rightChild # ********** End ********** # # 取得左子树 def getLeftChild(self): # ********** Begin ********** # return self.leftChild # ********** End ********** # # 设置根结点的值 def setRootVal(self, obj): # 将根结点的值赋值为obj # ********** Begin ********** # self.key = obj # ********** End ********** # # 取得根结点的值 def getRootVal(self): # ********** Begin ********** # return self.key # ********** End ********** # # 主程序 input_str = input() nodes = input_str.split(',') # 创建根节点 root = BinaryTree(nodes[0]) # 插入左子树和右子树 if len(nodes) > 1: root.insertLeft(nodes[1]) if len(nodes) > 2: root.insertRight(nodes[2]) # 前三行输出:对创建的二叉树按编号顺序输出结点 print(root.getRootVal()) left_child = root.getLeftChild
最新发布
03-18
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值