7-9 输出GPLT(20 分)
给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT....
这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT
的顺序打印,直到所有字符都被输出。
输入格式:
输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。
输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例:
pcTclnGloRgLrtLhgljkLhGFauPewSKgt
输出样例:
GPLTGPLTGLTGLGLL
#include <stdio.h>
#include <string.h>
int main(){
char a[10010];
int e=0,b=0,c=0,d=0;
scanf("%s",a);
int n=strlen(a);
for (int i=0;i<n;i++)
{
if (a[i]=='G'||a[i]=='g')
{
b++;
}
else if (a[i]=='P'||a[i]=='p')
{
c++;
}
else if (a[i]=='L'||a[i]=='l')
{
d++;
}
else if (a[i]=='T'||a[i]=='t')
{
e++;
}
}
while(1)
{
if (b>0)
{
printf("G");
b--;
}
if (c>0)
{
printf("P");
c--;
}
if (d>0)
{
printf("L");
d--;
}
if (e>0)
{
printf("T");
e--;
}
if (b==0&&c==0&&d==0&&e==0)//结合前面的while(1),他们的作用是若已查完4种大小写字母,就不管字符串后面,直接转行结束
{
printf("\n");
break;
}
}
return 0;
}