hdu 4396 More lumber is required(最短路,SPFA,4级)

More lumber is required

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/102400 K (Java/Others)
Total Submission(s): 909    Accepted Submission(s): 377


Problem Description
“More lumber is required” When the famous warcrafts player Sky wants to build a Central Town, he finds there is not enough lumber to build his Central Town. So he needs to collect enough lumber. He lets farmer John to do this work.
  There are several Sawmills have already been built in the world, around them are large forests. Sawmills are connected by bidirectional roads (a sawmill can be connected to itself). When he passes a road, he will get 10 lumber and consume a certain time. Sky needs K lumber. So John needs collect as least K lumber.
  Sawmills are labeled from 1 to N. John initiates at Sawmill S. When he finishes his work, Sky gives him another work: arrive at Sawmill T, and build the Central Town. John needs to design his route carefully because Sky wants to build this Central Town as early as possible. He turns you for help. Please help him calculate the minimum time he needs to finish this work (collect enough lumber and build the Central Town). If impossible just print -1.
  You can read the Sample Input and Output for more information.
 

Input
There are multiply test cases, in each test case:
The first line is two integers N (1<=N<=5000), M (0<=M<=100000) represent the number of sawmills and the number of the roads.
The next M line is three integers A B C (1<=A, B<=N; 1<=C<=100), means there exists a road connected A th sawmill and B th sawmill, and pass this road will cost C time.(The sawmills are labeled from 1 to N).
The last line is three integers S T K (1<=S, T<=N; 0<=K<=500), as mentioned as description.
 

Output
For each test case, print the result in a single line.
 

Sample Input
  
  
4 4 1 2 1 2 3 2 1 3 100 3 4 1 1 3 50
 

Sample Output
  
  
7
 

Author
Wanghang----School of Software Technology, Dalian University of Technology
 

Source
 

Recommend
zhuyuanchen520

思路:dis[u][k] 终点为S->u 经过k条边的最优结果,然后就是水了。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#define FOR(i,a,b) for(int i=a;i<=b;++i)
#define clr(f,z) memset(f,z,sizeof(f))
using namespace std;
const int mm=5009;
const int oo=1e9;
int dis[mm][550],head[mm],edge;
bool vis[mm][550];
class Edge
{
  public:int v,next,dis;
}e[mm*mm];
int n,m,S,T,K;
void data()
{
  clr(head,-1);edge=0;
}
void add(int u,int v,int c)
{
  e[edge].v=v;e[edge].dis=c;e[edge].next=head[u];head[u]=edge++;
}
int to(int x)
{
  if(x<K)return x;
  return K;
}
void spfa()
{
  FOR(i,0,n)FOR(j,0,K)dis[i][j]=oo,vis[i][j]=0;
  dis[S][0]=0;
  queue<pair<int,int> >Q;
  Q.push(make_pair(S,0));
  pair<int,int >z;int u,v,dep;
  while(!Q.empty())
  {
    z=Q.front();Q.pop();
    u=z.first;dep=z.second;
    vis[u][dep]=0;
    for(int i=head[u];~i;i=e[i].next)
    {
      v=e[i].v;
      if(dis[v][to(dep+1)]>dis[u][dep]+e[i].dis)
      {
        dis[v][to(dep+1)]=dis[u][dep]+e[i].dis;
        if(vis[v][to(dep+1)])continue;
        vis[v][to(dep+1)]=1;Q.push(make_pair(v,to(dep+1)));
      }
    }
  }
}
int main()
{
 int a,b,c;
 while(~scanf("%d%d",&n,&m))
 { data();
   FOR(i,1,m)
   {
     scanf("%d%d%d",&a,&b,&c);
     add(a,b,c);add(b,a,c);
   }
   scanf("%d%d%D",&a,&b,&c);
   S=a;T=b;K=c;
   if(K%10!=0)K=K/10+1;
   else K=K/10;
   spfa();
   if(dis[T][K]!=oo)printf("%d\n",dis[T][K]);
   else printf("-1\n");

 }
 return 0;
}




### RT-DETRv3 网络结构分析 RT-DETRv3 是一种基于 Transformer 的实时端到端目标检测算法,其核心在于通过引入分层密集正监督方法以及一系列创新性的训练策略,解决了传统 DETR 模型收敛慢和解码器训练不足的问题。以下是 RT-DETRv3 的主要网络结构特点: #### 1. **基于 CNN 的辅助分支** 为了增强编码器的特征表示能力,RT-DETRv3 引入了一个基于卷积神经网络 (CNN) 的辅助分支[^3]。这一分支提供了密集的监督信号,能够与原始解码器协同工作,从而提升整体性能。 ```python class AuxiliaryBranch(nn.Module): def __init__(self, in_channels, out_channels): super(AuxiliaryBranch, self).__init__() self.conv = nn.Conv2d(in_channels, out_channels, kernel_size=3, padding=1) self.bn = nn.BatchNorm2d(out_channels) def forward(self, x): return F.relu(self.bn(self.conv(x))) ``` 此部分的设计灵感来源于传统的 CNN 架构,例如 YOLO 系列中的 CSPNet 和 PAN 结构[^2],这些技术被用来优化特征提取效率并减少计算开销。 --- #### 2. **自注意力扰动学习策略** 为解决解码器训练不足的问题,RT-DETRv3 提出了一种名为 *self-att 扰动* 的新学习策略。这种策略通过对多个查询组中阳性样本的标签分配进行多样化处理,有效增加了阳例的数量,进而提高了模型的学习能力和泛化性能。 具体实现方式是在训练过程中动态调整注意力权重分布,确保更多的高质量查询可以与真实标注 (Ground Truth) 进行匹配。 --- #### 3. **共享权重解编码器分支** 除了上述改进外,RT-DETRv3 还引入了一个共享权重的解编码器分支,专门用于提供密集的正向监督信号。这一设计不仅简化了模型架构,还显著降低了参数量和推理时间,使其更适合实时应用需求。 ```python class SharedDecoderEncoder(nn.Module): def __init__(self, d_model, nhead, num_layers): super(SharedDecoderEncoder, self).__init__() decoder_layer = nn.TransformerDecoderLayer(d_model=d_model, nhead=nhead) self.decoder = nn.TransformerDecoder(decoder_layer, num_layers=num_layers) def forward(self, tgt, memory): return self.decoder(tgt=tgt, memory=memory) ``` 通过这种方式,RT-DETRv3 实现了高效的目标检测流程,在保持高精度的同时大幅缩短了推理延迟。 --- #### 4. **与其他模型的关系** 值得一提的是,RT-DETRv3 并未完全抛弃经典的 CNN 技术,而是将其与 Transformer 结合起来形成混合架构[^4]。例如,它采用了 YOLO 系列中的 RepNCSP 模块替代冗余的多尺度自注意力层,从而减少了不必要的计算负担。 此外,RT-DETRv3 还借鉴了 DETR 的一对一匹配策略,并在此基础上进行了优化,进一步提升了小目标检测的能力。 --- ### 总结 综上所述,RT-DETRv3 的网络结构主要包括以下几个关键组件:基于 CNN 的辅助分支、自注意力扰动学习策略、共享权重解编码器分支以及混合编码器设计。这些技术创新共同推动了实时目标检测领域的发展,使其在复杂场景下的表现更加出色。 ---
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值