1004: Octal Fractions 利用秦九韶定理进行小数的进制转换

该程序旨在将0到1范围内的八进制小数转换为等价的十进制小数。输入为形式为0.d1d2...dk的八进制数,输出为无尾随零的十进制表示。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1004: Octal Fractions


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K3535790Standard

Fractions in octal (base 8) notation can be expressed exactly in decimal notation. For example, 0.75 in octal is 0.963125 (7/8 + 5/64) in decimal. All octal numbers of n digits to the right of the octal point can be expressed in no more than 3n decimal digits to the right of the decimal point. Write a program to convert octal numerals between 0 and 1, inclusive, into equivalent decimal numerals. The input to your program will consist of octal numbers, one per line, to be converted. Each input number has the form 0.d1d2d3 ... dk, where the di are octal digits (0..7). There is no limit on k. Your output will consist of a sequence of lines of the form

0.d1d2d3 ... dk [8] = 0.D1D2D3 ... Dm [10]

where the left side is the input (in octal), and the right hand side the decimal (base 10) equivalent. There must be no trailing zeros, i.e. Dm is not equal to 0.

SAMPLE INPUT

0.75
0.0001
0.01234567

SAMPLE OUTPUT

0.75 [8] = 0.953125 [10]
0.0001 [8] = 0.000244140625 [10]
0.01234567 [8] = 0.020408093929290771484375 [10]
分析:0.12345【8】=1*1/8+2*1/(8*8)+3*1/(8*8*8)+4*1/(8*8*8*8)+5*1/(8*8*8*8*8)
=1000^5[1*1/8+2*1/(8*8)+3*1/(8*8*8)+4*1/(8*8*8*8)+5*1/(8*8*8*8*8)]/1000^5
=(1*125*1000^4+2*125^2*1000^3+3*125^3*1000^2+4*125^4*1000+5*125^5)/1000^5

=(1*125*1000^4+2*125^2*1000^3+3*125^3*1000^2+125^4*(4*1000+(5*125)))/1000^5
=(1*125*1000^4+2*125^2*1000^3+125^3*(3*1000^2+125*(4*1000+(5*125))))/1000^5
=(1*125*1000^4+125^2*(2*1000^3+125*(3*1000^2+125*(4*1000+(5*125)))))/1000^5
=125*(1*1000^4+125*(2*1000^3+125*(3*1000^2+125*(4*1000+(5*125))))))/1000^5
#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
const int maxn=1000;
int a[maxn+1];
int main()
{
    string str;
    while(cin>>str)
    {
        int n=str.size()-2;
        memset(a,0,sizeof(a));
        int t=maxn;
        for(int i=str.size()-1;i>=2;i--,t-=3)
        {
            a[t]+=str[i]-'0';
            for(int i=t;i>=0;i--)
            {
                if(a[i]>=10) a[i]%=10,a[i-1]++;
                else break;
            }
            for(int i=maxn;i>=0;i--) a[i]*=125;
            for(int i=maxn;i>=0;i--)
            {
                if(a[i]>=10) a[i-1]+=a[i]/10,a[i]%=10;
            }
        }
        int m;
        for(m=maxn;a[m]==0;m--);//去掉尾部的0
        cout<<str<<" [8] = 0.";
        for(int i=maxn-3*n+1;i<=m;i++) cout<<a[i];
        cout<<" [10]"<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值