2288: Game 将n个数排列成一个最大的数 通过sort实现

本文介绍了一款儿童数字游戏的算法实现,玩家通过排列给定的正整数来构建最大的可能整数。文章提供了完整的C++代码示例,演示了如何通过自定义排序比较函数实现目标。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

2288: Game


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K22662Standard

There are lots of number games for children. These games are pretty easy to play but not so easy to make. We will discuss about an interesting game here. Each player will be given N positive integer. (S)He can make a big integer by appending those integers after one another. Such as if there are 4 integers as 123, 124, 56, 90 then the following integers can be made – 1231245690, 1241235690, 5612312490, 9012312456, 9056124123 etc. In fact 24 such integers can be made. But one thing is sure that 9056124123 is the largest possible integer which can be made.

You may think that it’s very easy to find out the answer but will it be easy for a child who has just got the idea of number?

Input

Each input starts with a positive integer N (≤ 50). In next lines there are N positive integers(less than 10^50). Input is terminated by N = 0, which should not be processed.

Output

For each input set, you have to print the largest possible integer which can be made by appending all the N integers.

Sample Input

4
123 124 56 90
5
123 124 56 90 9
5
9 9 9 9 9
0

Sample Output

9056124123
99056124123
99999

 

Problem Source: UVA

 

 

 

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
bool cmp(string a,string b)
{
    string c=a+b;
    string d=b+a;
    return c>d;
}   
int main()
{
    int n;
    string a[60];
    while(cin>>n&&n)
    {
        for(int i=0;i<n;i++) cin>>a[i];
        sort(a,a+n,cmp);
        for(int i=0;i<n;i++) cout<<a[i];cout<<endl;
    }
    return 0;
}       

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值