2156: Drunk

 2156: Drunk


StatusIn/OutTIME LimitMEMORY LimitSubmit TimesSolved UsersJUDGE TYPE
stdin/stdout3s8192K1158262Standard
Jack is drunk again and he wants to walk out of the bar. But his steps are very strange. He first walks one step forward then the two backward then three forward and so on.

Input and Output

Each case will give you an integer to indicate how many steps forward is needed to walk out of bar. You should output the number of steps Jack needs to walk. You can assume that the result isless than 2 63.

Sample Input

1
2

Sample Output

1
6
#include<iostream>
using namespace std;
int main()
{
int a[100]={0};
int i,high=0,j,carry,n,temp;
while(cin>>n)
{
for(i=0;i<=99;i++)
a[i]=0;
if(n!=0)
   a[0]=1;
else
a[0]=0;
high=0;
    for(i=2;i<=2*n-1;i++)
{
carry=i;
for(j=0;j<=high;j++)
{
temp=a[j]+carry;
a[j]=temp%10;
carry=temp/10;
}
if(carry)
{
while(carry)
{
a[j++]=carry%10;
carry=carry/10;
high=j-1;
}
}
}
for(i=high;i>=0;i--)
cout<<a[i];
cout<<endl;
}
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值