Description
Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.
Input
The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.
1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000
Output
Sample Input
2 5 5 8 4 3 6831 1 3 4583 0 0 6592 0 1 3063 3 3 4975 1 3 2049 4 2 2104 2 2 781 5 5 10 2 4 9820 3 2 6236 3 1 8864 2 4 8326 2 0 5156 2 0 1463 4 1 2439 0 4 4373 3 4 8889 2 4 3133
Sample Output
71071 54223
题意:
比赛时想到了思路,忘记Kruskal这个算法是真难受,用Prim 邻接矩阵,敲太多这题刚好让我明白有些算法还没有万金油模板 ORZ。
思路:
征用所有人需要(n+m)*10000,只需生成省钱的最大生成树即可,Kruskal比较方便,权值排序从大到小。
但是有个问题,男女编号一样,所以需要将男生的编号加上女生总人数即可。
还有点可能不是联通的,所以遍历完所有边,或者找到n+m-1条边时 退出循环。
代码:
#include<stdio.h>
#include<algorithm>
using namespace std;
#define For(a,b,c) for(int a = b; a <= c; a++)
int f[20005];
struct Edge
{
int u, v, w;
}e[50005];
bool cmp(Edge x, Edge y)
{
return x.w > y.w;
}
int getf(int a)
{
return a == f[a] ? a : f[a] = getf(f[a]);
}
bool judge(int a, int b)
{
int fa = getf(a), fb = getf(b);
if(fa == fb) return true;
f[fa] = fb;
return false;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int n, m, r, u, v, w;
scanf("%d%d%d",&n,&m,&r);
For(i,1,r)
{
scanf("%d%d%d",&u,&v,&w);
e[i].u = u;
e[i].v = v + n;
e[i].w = w;
}
sort(e+1,e+1+r,cmp);
For(i,0,n+m) f[i] = i;
int cnt = 1, ans = (n+m)*10000;
for(int i = 1; cnt < n+m && i <= r; i++)
{
if(judge(e[i].u, e[i].v)) continue;
cnt++;
ans -= e[i].w;
}
printf("%d\n",ans);
}
return 0;
}