Prime Path
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 23967 | Accepted: 13242 |
Description

— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.
Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
1733
3733
3739
3779
8779
8179
Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input
3 1033 8179 1373 8017 1033 1033
Sample Output
6 7 0
思路:暴力广搜每次能改变数的可能,为了使代码精简些,牺牲了一点运行速度(将条件判断移到了 每次出队而不是入队)
代码:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<queue>
using namespace std;
#define mod 1000000007
#define ll long long
int pri[10005],book[10005];//pri记录素数,book记录该数是否出现过
struct node
{
int id,cnt;
}st,ne;
//筛素数
void prime_number(){
int i,j;
pri[0]=1;
pri[1]=1;
for(i=2;i<101;i++)
if(!pri[i])
for(j=i+i;j<10000;j+=i)
pri[j]=1;
}
int main(){
prime_number();
int T;
scanf("%d",&T);
while(T--){
memset(book,0,sizeof(book));
int m,i,s,TS;
scanf("%d%d",&st.id,&m);
st.cnt=0;
book[st.id]=1;
queue<node> q;
q.push(st);
while(!q.empty()){
st=q.front();
if(st.id==m)break;
q.pop();
ne.cnt=st.cnt+1;
//个位
for(i=0;i<10;i++){
ne.id=st.id/10*10+i;
if(pri[ne.id]||book[ne.id])continue;
book[ne.id]=1;
q.push(ne);
}
//十位
for(i=0;i<10;i++){
TS=st.id%10;
ne.id=st.id/100*100+i*10+TS;
if(pri[ne.id]||book[ne.id])continue;
book[ne.id]=1;
q.push(ne);
}
//百位
for(i=0;i<10;i++){
TS=st.id%100;
ne.id=st.id/1000*1000+i*100+TS;
if(pri[ne.id]||book[ne.id])continue;
book[ne.id]=1;
q.push(ne);
}
//千位
for(i=1;i<10;i++){
TS=st.id%1000;
ne.id=i*1000+TS;
if(pri[ne.id]||book[ne.id])continue;
book[ne.id]=1;
q.push(ne);
}
}
if(st.id==m)printf("%d\n",st.cnt);
else printf("Impossible\n");
}
return 0;
}