题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1020
题目描述:
Encoding
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18849 Accepted Submission(s): 8137
Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:
1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.
2. If the length of the sub-string is 1, '1' should be ignored.
1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.
2. If the length of the sub-string is 1, '1' should be ignored.
Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
Output
For each test case, output the encoded string in a line.
Sample Input
2 ABC ABBCCC
Sample Output
ABC A2B3C
题意:按照特定规则编码。
题解:模拟。
代码:
/*
hdu:Encoding
*/
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int N=0;
char ch='\0';
int Num=0;
char GStr[10000+5]={'\0'};
/*for test*/
int test()
{
return(0);
}
/*main process*/
int MainProc()
{
scanf("%d",&N);
getchar();
while(N--)
{
gets(GStr);
//getchar();//read the \n
int Len=strlen(GStr);
int i=0;
ch=GStr[0];
Num=1;
for(i=1;i<=Len;i++)
{
if(ch==GStr[i])
{
Num++;
}
else
{
if(Num>1)
{
printf("%d",Num);
}
printf("%c",ch);
Num=1;
ch=GStr[i];
}
}
printf("\n");
}
return(0);
}
int main()
{
MainProc();
return(0);
}