hdu 1335 Basically Speaking

本文详细阐述了如何设计并实现一种能将任意进制数转换为其他任意进制数的功能,包括从任意进制到十进制的转换以及从十进制到任意进制的转换过程。特别关注了在转换过程中遇到的字符表示问题,例如使用字母表示大于9的数字,并提供了相应的代码实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目地址:

http://acm.hdu.edu.cn/showproblem.php?pid=1335

题目描述:

Basically Speaking

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2427    Accepted Submission(s): 922


Problem Description
The Really Neato Calculator Company, Inc. has recently hired your team to help design their Super Neato Model I calculator. As a computer scientist you suggested to the company that it would be neato if this new calculator could convert among number bases. The company thought this was a stupendous idea and has asked your team to come up with the prototype program for doing base conversion. The project manager of the Super Neato Model I calculator has informed you that the calculator will have the following neato features: 
It will have a 7-digit display.

Its buttons will include the capital letters A through F in addition to the digits 0 through 9.

It will support bases 2 through 16. 
 

Input
The input for your prototype program will consist of one base conversion per line. There will be three numbers per line. The first number will be the number in the base you are converting from. The second number is the base you are converting from. The third number is the base you are converting to. There will be one or more blanks surrounding (on either side of) the numbers. There are several lines of input and your program should continue to read until the end of file is reached.
 

Output
The output will only be the converted number as it would appear on the display of the calculator. The number should be right justified in the 7-digit display. If the number is to large to appear on the display, then print "ERROR'' (without the quotes) right justified in the display. 
 

Sample Input
  
  
1111000 2 10 1111000 2 16 2102101 3 10 2102101 3 15 12312 4 2 1A 15 2 1234567 10 16 ABCD 16 15
 

Sample Output
  
  
120 78 1765 7CA ERROR 11001 12D687 D071

题意:

任意进制间的转换。

题解:

就是吧m进制转化为10进制(辗转相乘,连乘,注意连乘技巧,叠加乘,而不是直接取够着m的几次方),然后再吧10进制转化为n进制(辗转相除)。注意个别的位上是字母的情况。

代码:

#include<stdio.h>
#include<string.h>
#define SWAP(x,y) x^=y;y^=x;x^=y;
char m_str[100],n_str[100];
int m_base=0,n_base=0;//base number
//m base convert into the n base
int m_to_n(int mb,char *ms,int nb,char *ns)
{
    int len_m=strlen(ms),len_n=0;
    int tens=0,i=0,j=0;
    for(i=0;i<=len_m-1;i++) tens=ms[i]<='9' ? tens*mb+ms[i]-'0' :tens*mb+ms[i]-'A'+10 ;//convert to the 10 base, low string bit map to high number bit
    while(tens>0) {ns[len_n++]=tens%nb>=10 ? tens%nb-10+'A' : tens%nb+'0';tens/=nb;}
    i=0;j=len_n-1;n_str[len_n]='\0';
    while(i<j){SWAP(n_str[i],n_str[j]);i++;j--;}
    return(0);
}
int main()
{
    while(scanf("%s%d%d",m_str,&m_base,&n_base)!=EOF)
    {
        m_to_n(m_base,m_str,n_base,n_str);
        if(strlen(n_str)<=7) printf("%7s\n",n_str);
        else printf("%7s\n","ERROR");
    }
    return(0);
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值