poj 2478 Farey Sequence 欧拉函数递推打表

Farey Sequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14434 Accepted: 5719

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9


题意:求f(n)中数的个数。

思路:可以看出f(n)=f(n-1)+phi(n)(法雷数列中分母为n的项,其分子与其互质,所以分母为n的数的个数即为phi(n)),打表求出1e6内的欧拉函数,累加即可


代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <map>
using namespace std;
long long p[1000006];
void phi(long long N)    
{    
    for(long long i=1; i<N; i++)  p[i] = i;    
    for(long long i=2; i<N; i+=2) p[i] >>= 1;    
    for(long long i=3; i<N; i+=2)    
    {    
        if(p[i] == i)    
        {    
            for(long long j=i; j<N; j+=i)    
                p[j] = p[j] - p[j] / i;    
        }    
    }    
}    
int main(int argc, char const *argv[])
{   long long i,j,k,m,n,t;
	long long sum=0;
	phi(1000001);
    while(~scanf("%lld",&n))
    {   sum=0;
    	if(n==0)break;
    	for(i=2;i<=n;i++)sum+=p[i];
    	printf("%lld\n",sum);	

    }
	return 0;
}



                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值