link:http://acm.hdu.edu.cn/showproblem.php?pid=2955
Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.
For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.
His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.
Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
2
4
6
题解:
01背包问题,
把花费看做概率,价值看做银行里的钱,
用一维数组,sum存所有银行的钱
for i= 1……n
for j=sum……m[i]
dp[j]=max(dp[j],dp[j-m[i]]*(1-p[i]);
1-p[i]是安全概率,dp存的是偷完这家银行你的安全概率多少,安全概率是1减去被抓的概率
AC代码:
#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
int main()
{
int i,j,t,n,m[105],s;
double p[105],P,dp[10005];
scanf("%d",&t);
while(t--)
{
s=0;
scanf("%lf%d",&P,&n);
P=1-P;//变成安全概率
for(i=0;i<n;i++)
{
scanf("%d%lf",&m[i],&p[i]);
s+=m[i];
}
dp[0]=1.0;
for(i=1;i<=s;i++)
dp[i]=0.0;
for(i=0;i<n;i++)
{
for(j=s;j>=m[i];j--)
dp[j]=max(dp[j],dp[j-m[i]]*(1-p[i]));
}
for(i=s;i>=0;i--)
{
if(dp[i]>=P)//当偷得钱之后的安全概率大于最初设置的那个,就把这个输出
{
printf("%d\n",i);
break;
}
}
}
return 0;
}