Robberies||HDU2955

link:http://acm.hdu.edu.cn/showproblem.php?pid=2955
Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

这里写图片描述

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

题解:
01背包问题,
把花费看做概率,价值看做银行里的钱,
用一维数组,sum存所有银行的钱
for i= 1……n
for j=sum……m[i]
dp[j]=max(dp[j],dp[j-m[i]]*(1-p[i]);
1-p[i]是安全概率,dp存的是偷完这家银行你的安全概率多少,安全概率是1减去被抓的概率
AC代码:

#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
int main()
{
    int i,j,t,n,m[105],s;
    double p[105],P,dp[10005];
    scanf("%d",&t);
    while(t--)
    {
        s=0;
        scanf("%lf%d",&P,&n);
        P=1-P;//变成安全概率 
        for(i=0;i<n;i++)
        {
            scanf("%d%lf",&m[i],&p[i]);
            s+=m[i];
        }
        dp[0]=1.0;
        for(i=1;i<=s;i++)
            dp[i]=0.0;
        for(i=0;i<n;i++)
        {
            for(j=s;j>=m[i];j--)
               dp[j]=max(dp[j],dp[j-m[i]]*(1-p[i]));
        }
        for(i=s;i>=0;i--)
        {
            if(dp[i]>=P)//当偷得钱之后的安全概率大于最初设置的那个,就把这个输出 
            {
                printf("%d\n",i);
                break;
            }
        }
    }
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三更鬼

谢谢老板!

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值