More is better||HDU1856

本文介绍了一个基于并查集算法的经典问题——通过一系列直接好友关系找出最多能保持联系的好友数量。该问题需要利用并查集进行数据结构的设计与实现,最终找到最大好友集合的数量。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1856

Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.


Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output

4
2

Hint

A and B are friends(direct or indirect), B and C are friends(direct or indirect), 
then A and C are also friends(indirect).

 In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

题解:简单并查集运用

#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
const int N=10000003;
using namespace std;
int mmax,par[N],num[N];
void initial()/*初始化*/  
{  
    int i;  
    for(i=1;i<N;i++)  
    {  
        par[i]=i;  
        num[i]=1;/*开始时数量都为1,根节点为自己*/  
    }  
}
int find(int x)//寻找根节点 
{
    if(x!=par[x])
      par[x]=find(par[x]);
    return par[x];
}
void unite(int x,int y)//合并 
{
    int fx,fy;
    fx=find(x);
    fy=find(y);
    if(fx!=fy)
    {
        par[fx]=fy;
        num[fy]+=num[fx];
        if(num[fy]>mmax) mmax=num[fy];
    }
}
bool cmp(int x,int y)
{
    return x>y;
}
int main()
{
    int a,i,n,b,m;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
        {
            printf("1\n");
            continue;
        }
        mmax=INT_MIN;
        initial();
        for(i=0;i<n;i++)
        {
            scanf("%d %d",&a,&b);
//          if(a>m) m=a;
//          if(b>m) m=b;
            unite(a,b);
        }
//      sort(num+1,num+2+m,cmp);
//      for(i=1;i<=m;i++)
//      {
//          if(num[i]>max)
//            max=num[i];
//      }
        printf("%d\n",mmax);
    }
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三更鬼

谢谢老板!

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值