华为&DSV模拟实验(二)✍

华为DSV模拟实验二

根据模拟实验二 来进行 扩展,实现多级联情况下的DSV配置。

在这里插入图片描述
针对于上次的DSV模拟实验(一)进行扩展

也对上次的模拟实验一配置进行了修改。

修改如下:
将所有路由器的私有网段进行调整,宣告到ospf的其他非骨干区域;
在HUB上,进行三类LSA的拒绝传递;
将静态汇总路由重发布到OSPF中。

防止:分支的私网网段故障引起网络故障,在 HUB总部上进行一个路由汇总信息。

扩展实验中的重点
R7 R8为R3的下联
R9 R10为R4的下联
这些下联互访也是不要通过总部访问;
R11为R1HUB的备份;当R1故障的时候 通过R11来进行访问的正常进行。

主要配置

R1:

interface GigabitEthernet0/0/0
 ip address 200.1.1.1 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 192.168.1.100 255.255.255.0 
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface Tunnel0/0/0
 ip address 10.1.1.1 255.255.255.0 
 tunnel-protocol gre p2mp
 source 200.1.1.1
 ospf cost 10(修改链路cost值---为实现主备hub)
 ospf network-type p2mp
 ospf filter-lsa-out summary(在ABR的接口下这配置ospf fliter-lsa-out summary过滤从该接口通告的3类LSA。)
 nhrp redirect
 nhrp entry multicast dynamic
#
ospf 100 router-id 1.1.1.1 
 import-route static
 area 0.0.0.0 
  network 10.1.1.0 0.0.0.255 
 area 0.0.0.1 (调整 私网网段放到非骨干区域)
  network 192.168.1.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 200.1.1.2
ip route-static 192.168.0.0 255.255.0.0 Tunnel0/0/0 (汇总私网地址路由)

R11

R11:
interface GigabitEthernet0/0/0
 ip address 200.1.2.1 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 192.168.2.100 255.255.255.0 
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface Tunnel0/0/0
 ip address 10.1.1.2 255.255.255.0 
 tunnel-protocol gre p2mp
 source GigabitEthernet0/0/0
 ospf cost 50 (修改链路cost)
 ospf network-type p2mp
 nhrp redirect
 nhrp entry multicast dynamic
#
ospf 100 router-id 2.2.2.2 
 import-route static cost 50  重发ub
 area 0.0.0.0 
  network 10.1.1.0 0.0.0.255 
 area 0.0.0.2 
  network 192.168.2.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 200.1.2.2
ip route-static 192.168.0.0 255.255.0.0 Tunnel0/0/0

R2(ISP只需配置接口IP地址)

interface GigabitEthernet0/0/0
 ip address 200.1.1.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 200.1.3.2 255.255.255.0 
#
interface GigabitEthernet0/0/2
 ip address 200.1.4.2 255.255.255.0 
#
interface GigabitEthernet4/0/0
 ip address 200.1.7.2 255.255.255.0 
#
interface GigabitEthernet4/0/1
 ip address 200.1.8.2 255.255.255.0 
#
interface GigabitEthernet4/0/2
 ip address 200.1.9.2 255.255.255.0 
#
interface GigabitEthernet4/0/3
 ip address 200.1.10.2 255.255.255.0 
#
interface GigabitEthernet6/0/0
 ip address 200.1.2.2 255.255.255.0 

R3

interface GigabitEthernet0/0/0
 ip address 192.168.3.100 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 200.1.3.1 255.255.255.0 
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface Tunnel0/0/0
 ip address 10.1.1.3 255.255.255.0 
 tunnel-protocol gre p2mp
 source 200.1.3.1
 ospf network-type p2mp
 ospf dr-priority 0  
 nhrp redirect     (是在与R3的下联中nhrp的设定)
 nhrp shortcut  (是在R1 R4之间的 nhrp 设定)
 nhrp entry multicast dynamic   (命令用来使能将动态注册的分支加入NHRP组播成员表功能。)
 nhrp entry 10.1.1.1 200.1.1.1 register  主hub
 nhrp entry 10.1.1.2 200.1.2.1 register  备hub
#
ospf 100 router-id 3.3.3.3 
 area 0.0.0.0 
  network 10.1.1.0 0.0.0.255 
 area 0.0.0.3 
  network 192.168.3.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 200.1.3.2

R4 与R3配置相似

interface GigabitEthernet0/0/0
 ip address 192.168.4.100 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 200.1.4.1 255.255.255.0 
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface Tunnel0/0/0
 ip address 10.1.1.4 255.255.255.0 
 tunnel-protocol gre p2mp
 source 200.1.4.1
 ospf network-type p2mp
 ospf dr-priority 0
 nhrp redirect
 nhrp shortcut
 nhrp entry multicast dynamic
 nhrp entry 10.1.1.1 200.1.1.1 register
 nhrp entry 10.1.1.2 200.1.2.1 register
#
ospf 100 router-id 4.4.4.4 
 area 0.0.0.0 
  network 10.1.1.0 0.0.0.255 
 area 0.0.0.4 
  network 192.168.4.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 200.1.4.2

R7

interface GigabitEthernet0/0/0
 ip address 200.1.7.1 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 192.168.5.100 255.255.255.0 
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface Tunnel0/0/0
 ip address 10.1.1.7 255.255.255.0 
 tunnel-protocol gre p2mp
 source GigabitEthernet0/0/0
 ospf network-type p2mp
 nhrp shortcut
 nhrp entry 10.1.1.3 200.1.3.1 register  (上联 R3)
#
ospf 100 router-id 7.7.7.7 
 area 0.0.0.0 
  network 10.1.1.0 0.0.0.255 
 area 0.0.0.7 
  network 192.168.5.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 200.1.7.2

R8 与R7配置相似

interface GigabitEthernet0/0/0
 ip address 200.1.8.1 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 192.168.6.100 255.255.255.0 
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface Tunnel0/0/0
 ip address 10.1.1.8 255.255.255.0 
 tunnel-protocol gre p2mp
 source GigabitEthernet0/0/0
 ospf network-type p2mp
 nhrp shortcut
 nhrp entry 10.1.1.3 200.1.3.1 register 
#
ospf 100 router-id 8.8.8.8 
 area 0.0.0.0 
  network 10.1.1.0 0.0.0.255 
 area 0.0.0.8 
  network 192.168.6.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 200.1.8.2

R9

interface GigabitEthernet0/0/0
 ip address 200.1.9.1 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 192.168.7.100 255.255.255.0 
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface Tunnel0/0/0
 ip address 10.1.1.9 255.255.255.0 
 tunnel-protocol gre p2mp
 source GigabitEthernet0/0/0
 ospf network-type p2mp
 nhrp shortcut
 nhrp entry 10.1.1.4 200.1.4.1 register(上联 R4)
#
ospf 100 router-id 9.9.9.9 
 area 0.0.0.0 
  network 10.1.1.0 0.0.0.255 
 area 0.0.0.9 
  network 192.168.7.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 200.1.9.2

R10 配置与R9相似

interface GigabitEthernet0/0/0
 ip address 200.1.10.1 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 192.168.8.100 255.255.255.0 
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface Tunnel0/0/0
 ip address 10.1.1.10 255.255.255.0 
 tunnel-protocol gre p2mp
 source GigabitEthernet0/0/0
 ospf network-type p2mp
 nhrp shortcut
 nhrp entry 10.1.1.4 200.1.4.1 register
#
ospf 100 router-id 10.10.10.10 
 area 0.0.0.0 
  network 10.1.1.0 0.0.0.255 
 area 0.0.0.10 
  network 192.168.8.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 200.1.10.2

上述配置拓扑文件 供大家参考使用
链接:https://pan.baidu.com/s/1eVCqA6a3UO8Dmv_euzr0NA
提取码:nwxg

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值