1037 Magic Coupon (25)
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!
For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 10^5^, and it is guaranteed that all the numbers will not exceed 2^30^.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
解题思路:
两数组中的值两两相乘使值最大。
1.先排序,小的在前。
2.不能使用同号来判断,那样可能会判断两遍。要明确地先判同负,再判同正。
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1e5+10;
bool cmp(int a,int b){
return a<b;
}
int a[maxn],b[maxn];
int main(){
int nc,np,ans=0;
scanf("%d",&nc);
for(int i=0;i<nc;i++)
scanf("%d",&a[i]);
scanf("%d",&np);
for(int i=0;i<np;i++)
scanf("%d",&b[i]);
sort(a,a+nc,cmp);
sort(b,b+np,cmp);
int i=0,j=0,lena=nc-1,lenb=np-1;
while(a[i]<0&&b[i]<0){
ans+=(a[i]*b[i]);
i++;
j++;
}
while(a[lena]>0&&b[lenb]>0){
ans+=(a[lena]*b[lenb]);
lena--;
lenb--;
}
printf("%d",ans);
return 0;
}