1035 Password (20)

本文介绍了一个用于检查和修改容易混淆的密码的程序。该程序能够将特定字符替换为更易于区分的符号,如将1替换为@,0替换为%,l替换为L,O替换为o,以减少密码误读的可能性。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1035 Password (20)
To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line “There are N accounts and no account is modified” where N is the total number of accounts. However, if N is one, you must print “There is 1 account and no account is modified” instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa
Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa
Sample Input 2:

1
team110 abcdefg332
Sample Output 2:

There is 1 account and no account is modified
Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333
Sample Output 3:

There are 2 accounts and no account is modified

解题思路:
把密码中的1改为@,0改为%,l改为L,O改为o。
1.设置结构体数组,另加一个判断是否需要修改的标记。
2.直接在读入时判断并修改,统计修改人数m。
3.当m为零时,根据n值判断输出。m不为零时,输出标记book为true的。

#include<cstdio> 
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
struct Node{
    char name[15],password[15];
    bool book;
}node[1010];
int main(){
    int n,m=0;
    bool book[1010]={false};
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%s %s",node[i].name ,node[i].password );
        int len=strlen(node[i].password );
        for(int j=0;j<len;j++){
            if(node[i].password[j]=='1') {
                node[i].password[j]='@';    
                node[i].book =true;
            }else if(node[i].password[j]=='0'){
                node[i].password[j]='%';
                node[i].book =true; 
            }else if(node[i].password[j]=='l'){
                node[i].password[j]='L';    
                node[i].book =true;
            }else if(node[i].password[j]=='O'){
                node[i].password[j]='o';    
                node[i].book =true;
            }
        }
        if(node[i].book ==true) m++;
    }
    if(m==0){
        if(n==1) printf("There is 1 account and no account is modified\n");
        else printf("There are %d accounts and no account is modified\n",n);
    }else{
        printf("%d\n",m);
        for(int i=0;i<n;i++){
            if(node[i].book ==true){
                printf("%s %s\n",node[i].name ,node[i].password );
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值