1027 Colors in Mars (20)
People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.
Input
Each input file contains one test case which occupies a line containing the three decimal color values.
Output
For each test case you should output the Mars RGB value in the following format: first output “#”, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a “0” to the left.
Sample Input
15 43 71
Sample Output
#123456
把给定数字转化为13进制数,其中10-13用A,B,C表示。
#include<cstdio>
int main(){
int r,g,b;
char change[15]={'0','1','2','3','4','5','6','7','8','9','A','B','C'}; //可以直接写成 char c[14] = {"0123456789ABC"};
scanf("%d%d%d",&r,&g,&b);
printf("#");
printf("%c%c%c%c%c%c",change[r/13],change[r%13],change[g/13],change[g%13],change[b/13],change[b%13]);
return 0;
}