hdu 1358 Period(求循环节)

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5684    Accepted Submission(s): 2738


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
  
  
3 aaa 12 aabaabaabaab 0
 

Sample Output
  
  
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 
题意:给你一个字符串S,问你有多少个i使得S的前i个字符组成的前缀是某个字符串重复K次得到,输出所有存在K的i和对应的K。
比如字符串aabaabaabaab,只有当i=2,6,9,12时K存在,且分别为2,2,3,4.

思路:i%(i-Next[i])==0&&Next[i]!=0i个字符可以组成一个周期串。

#include<bits/stdc++.h>
using namespace std;
const int maxn=1100000;
int n,m;
char pattern[maxn];
int Next[maxn];

void get_next(){
    int i=0,j=-1;
    Next[0]=-1;
    while(i<m){
        if(j==-1||pattern[j]==pattern[i]){
            j++,i++;
            Next[i]=j;
            if(i%(i-Next[i])==0&&Next[i]!=0)
                printf("%d %d\n",i,i/(i-Next[i]));
        }
        else
            j=Next[j];
    }
}

int main(){
    int case1=1;
    while(scanf("%d",&m)!=EOF){
        if(m==0)
            break;
        scanf("%s",pattern);
        printf("Test case #%d\n",case1++);
        get_next();
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值