hdu 5056 Boring count(尺取法)

本文介绍了一个算法问题的解决方案,该问题要求计算字符串中所有子串的数量,这些子串中每个字母出现的次数不超过给定值K。通过使用滑动窗口技术和哈希映射的方法,有效地解决了这一问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Boring count

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 928    Accepted Submission(s): 381


Problem Description
You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.
 

Input
In the first line there is an integer T , indicates the number of test cases.
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.

[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
 

Output
For each case, output a line contains the answer.
 

Sample Input
  
  
3 abc 1 abcabc 1 abcabc 2
 

Sample Output
  
  
6 15 21

题意:出现字母不能超过k次的串的个数

思路:尺取法推进,map hash即可。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <map>
using namespace std;
#define N 100050
char s[N],a[N];
map<char,int>mp;
int main()
{
    int T,t;
    scanf("%d",&T);
    while(T--)
    {
        mp.clear();
        scanf("%s %d",s,&t);
        int r=0,cnt=0;
        long long ans=0;
        int len=strlen(s);
        for(int i=0; i<len; i++)
        {
            if(mp[s[r]]<=t)
                ans+=r-i;
            else ans+=r-i-1;
            while(r<len&&mp[s[r]]<t)
            {
                mp[s[r]]++;
                ans++;
                r++;
            }
            mp[s[i]]--;
        }
        printf("%lld\n",ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值