Boring count
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 928 Accepted Submission(s): 381
Problem Description
You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.
Input
In the first line there is an integer T , indicates the number of test cases.
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.
[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.
[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
Output
For each case, output a line contains the answer.
Sample Input
3 abc 1 abcabc 1 abcabc 2
Sample Output
6 15 21
题意:出现字母不能超过k次的串的个数
思路:尺取法推进,map hash即可。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <map>
using namespace std;
#define N 100050
char s[N],a[N];
map<char,int>mp;
int main()
{
int T,t;
scanf("%d",&T);
while(T--)
{
mp.clear();
scanf("%s %d",s,&t);
int r=0,cnt=0;
long long ans=0;
int len=strlen(s);
for(int i=0; i<len; i++)
{
if(mp[s[r]]<=t)
ans+=r-i;
else ans+=r-i-1;
while(r<len&&mp[s[r]]<t)
{
mp[s[r]]++;
ans++;
r++;
}
mp[s[i]]--;
}
printf("%lld\n",ans);
}
return 0;
}