Hard challenge
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)Total Submission(s): 286 Accepted Submission(s): 103
Problem Description
There are
n
points on the plane, and the
i
th points has a value
vali
, and its coordinate is
(xi,yi)
. It is guaranteed that no two points have the same coordinate, and no two points makes the line which passes them also passes the origin point. For every two points, there is a segment connecting them, and the segment has a value which equals the product of the values of the two points. Now HazelFan want to draw a line throgh the origin point but not through any given points, and he define the score is the sum of the values of all segments that the line crosses. Please tell him the maximum score.
Input
The first line contains a positive integer
T(1≤T≤5)
, denoting the number of test cases.
For each test case:
The first line contains a positive integer n(1≤n≤5×104) .
The next n lines, the i th line contains three integers xi,yi,vali(|xi|,|yi|≤109,1≤vali≤104) .
For each test case:
The first line contains a positive integer n(1≤n≤5×104) .
The next n lines, the i th line contains three integers xi,yi,vali(|xi|,|yi|≤109,1≤vali≤104) .
Output
For each test case:
A single line contains a nonnegative integer, denoting the answer.
A single line contains a nonnegative integer, denoting the answer.
Sample Input
2 2 1 1 1 1 -1 1 3 1 1 1 1 -1 10 -1 0 100
Sample Output
1 1100
Source
————————————————————————————————————
题目的意思是给出n个点,n个点两两之间形成线段价值为端点之积,现在过原点做一条直线,价值为穿过的线段的和,求最大价值
思路:很明显答案就是直线两边点的和的积,我们先按角度对所有点排个序,再搞波前缀和,枚举直线穿过每个点,算出两边的价值,把这个点放到较小的一侧,求最大即可。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <map>
#include <set>
#include <algorithm>
#include <complex>
#include <vector>
#include <bitset>
#include <stack>
#include <queue>
#include <unordered_map>
#include <functional>
using namespace std;
#define LL long long
const int INF=0x3f3f3f3f;
const double pi=acos(-1.0);
int n;
struct node
{
int x,y;
LL val;
double z;
bool operator<(const node &a)const
{
return z<a.z;
}
}a[50009];
LL sum[50009];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d%d%lld",&a[i].x,&a[i].y,&a[i].val);
if(a[i].x>0)
{
a[i].z=atan(1.0*a[i].y/a[i].x);
if(a[i].z<0) a[i].z+=2*pi;
}
else if(a[i].x==0)
{
if(a[i].y>0) a[i].z=pi/2;
else a[i].z=pi*3/2;
}
else
{
a[i].z=atan(1.0*a[i].y/a[i].x);
a[i].z+=pi;
}
}
sort(a+1,a+1+n);
sum[0]=0;
for(int i=1;i<=n;i++) sum[i]=sum[i-1]+a[i].val;
int k=2;
LL ma=0;
for(int i=1;i<=n;i++)
{
while(1)
{
double p=a[k].z-a[i].z;
if(p<0) p+=2*pi;
if(p>pi||k==i) break;
k=(k+1)%n;
if(!k) k=n;
}
LL sum1,sum2;
if(k>i) sum1=sum[k-1]-sum[i],sum2=sum[n]-sum1-a[i].val;
else sum2=sum[i-1]-sum[k-1],sum1=sum[n]-sum2-a[i].val;
if(sum1<sum2) sum1+=a[i].val;
else sum2+=a[i].val;
ma=max(ma,sum1*sum2);
}
printf("%lld\n",ma);
}
return 0;
}