HDU-2276(矩阵快速幂)

                                     Kiki & Little Kiki 2

        Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
        Total Submission(s): 3372    Accepted Submission(s): 1815

Problem Description

There are n lights in a circle numbered from 1 to n. The left of light 1 is light n, and the left of light k (1< k<= n) is the light k-1.At time of 0, some of them turn on, and others turn off. 
Change the state of light i (if it's on, turn off it; if it is not on, turn on it) at t+1 second (t >= 0), if the left of light i is on !!! Given the initiation state, please find all lights’ state after M second. (2<= n <= 100, 1<= M<= 10^8)

Input

The input contains one or more data sets. The first line of each data set is an integer m indicate the time, the second line will be a string T, only contains '0' and '1' , and its length n will not exceed 100. It means all lights in the circle from 1 to n.
If the ith character of T is '1', it means the light i is on, otherwise the light is off.

Output

For each data set, output all lights' state at m seconds in one line. It only contains character '0' and '1.

Sample Input

1

0101111

10

100000001

Sample Output

1111000

001000010

#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

struct node
{
    int mt[102][102];
}a,b;
int  n;
char str[102];

node mult(node x,node y)
{
    node z;
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        {
            z.mt[i][j]=0;
            for(int k=0;k<n;k++)
                z.mt[i][j]+=x.mt[i][k]*y.mt[k][j];
            z.mt[i][j]%=2;
        }
    return z;
}

node qpow(int t)
{
    node z;
    memset(b.mt,0,sizeof(b.mt));
    memset(z.mt,0,sizeof(z.mt));
    for(int i=0;i<n;i++)
        b.mt[i][0]=(int)str[i]-'0';
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
        {
            if(i==j||i==j+1||(i==0&&j==n-1))
                a.mt[i][j]=1;
            else
                a.mt[i][j]=0;
        }
        z.mt[i][i]=1;
    }
    while(t)
    {
        if(t&1)
            z=mult(z,a);
        a=mult(a,a);
        t=t>>1;
    }
    z=mult(z,b);
    return z;
}

int main()
{
    int v;
    while(~scanf("%d%s",&v,str))
    {
        n=strlen(str);
        node z=qpow(v);
        for(int i=0;i<n;i++)
            printf("%d",z.mt[i][0]);
        printf("\n");
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值