Equations(哈希)


Link:http://acm.hdu.edu.cn/showproblem.php?pid=1496


Equations

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6091    Accepted Submission(s): 2467


Problem Description
Consider equations having the following form: 

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
 

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

Output
For each test case, output a single line containing the number of the solutions.
 

Sample Input
  
  
1 2 3 -4 1 1 1 1
 

Sample Output
  
  
39088 0


AC code:

#include<iostream>
#include<cmath>
#include<climits>
#include<cstring>
#include<queue>
#include<vector>
#include<algorithm>
#include<string.h>
#include<cstdio>
#define MAXN 1000010
#define LL long long
using namespace std;
int ha[MAXN*2];
int sum;
int main()
{
    int i,j,a,b,c,d;
    while(~scanf("%d%d%d%d",&a,&b,&c,&d))
    {
        if((a<0&&b<0&&c<0&&d<0)||(a>0&&b>0&&c>0&&d>0))
        {

            printf("0\n");
        }
        else
        {
            memset(ha,0,sizeof(ha));
            for(i=1; i<=100; i++)
            {
                for(j=1; j<=100; j++)
                {
                    ha[a*i*i+b*j*j+1000000]++;
                }
            }
            sum=0;
            for(i=1; i<=100; i++)
            {

                for(j=1; j<=100; j++)
                {

                    sum+=ha[-c*i*i-d*j*j+1000000];
                }
            }
            LL ans=sum*2*2*2*2;
            printf("%I64d\n",ans);
        }

    }
    return 0;
}



空间优化哈希算法:


AC code:

#include<iostream>
#include<cmath>
#include<climits>
#include<cstring>
#include<queue>
#include<vector>
#include<algorithm>
#include<string.h>
#include<cstdio>
#define MAXN 20010
#define LL long long
using namespace std;
int f[MAXN],g[MAXN];
LL ans;
int has(int k)
{
    int t=k%MAXN;
    if(t<0)
    {
        t+=MAXN;
    }
    while(f[t]!=0&&g[t]!=k)
    {
        t=(t+1)%MAXN;
    }
    return t;
}
int main()
{
    int a,b,c,d,i,j,s,p;
    while(scanf("%d%d%d%d",&a,&b,&c,&d)>0)
    {
        if(a>0&&b>0&&c>0&&d>0||a<0&&b<0&&c<0&&d<0)
        {
            printf("0\n");
            continue;
        }
        memset(f,0,sizeof(f));
        for(i=1; i<=100; i++)
        {
            for(j=1; j<=100; j++)
            {
                s=a*i*i+b*j*j;
                p=has(s);
                f[p]++;
                g[p]=s;
            }
        }
        ans=0;
        for(i=1; i<=100; i++)
        {
            for(j=1; j<=100; j++)
            {
                s=-c*i*i-d*j*j;
                p=has(s);
                ans+=f[p];
            }
        }
        printf("%I64d\n",ans*16);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值