hdu Problem-1426数独问题(dfs+回溯+枚举)

Sudoku Killer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8089    Accepted Submission(s): 2497


Problem Description
自从2006年3月10日至11日的首届数独世界锦标赛以后,数独这项游戏越来越受到人们的喜爱和重视。
据说,在2008北京奥运会上,会将数独列为一个单独的项目进行比赛,冠军将有可能获得的一份巨大的奖品———HDU免费七日游外加lcy亲笔签名以及同hdu acm team合影留念的机会。
所以全球人民前仆后继,为了奖品日夜训练茶饭不思。当然也包括初学者linle,不过他太笨了又没有多少耐性,只能做做最最基本的数独题,不过他还是想得到那些奖品,你能帮帮他吗?你只要把答案告诉他就可以,不用教他是怎么做的。

数独游戏的规则是这样的:在一个9x9的方格中,你需要把数字1-9填写到空格当中,并且使方格的每一行和每一列中都包含1-9这九个数字。同时还要保证,空格中用粗线划分成9个3x3的方格也同时包含1-9这九个数字。比如有这样一个题,大家可以仔细观察一下,在这里面每行、每列,以及每个3x3的方格都包含1-9这九个数字。

例题:


答案:

 

Input
本题包含多组测试,每组之间由一个空行隔开。每组测试会给你一个 9*9 的矩阵,同一行相邻的两个元素用一个空格分开。其中1-9代表该位置的已经填好的数,问号(?)表示需要你填的数。
 

Output
对于每组测试,请输出它的解,同一行相邻的两个数用一个空格分开。两组解之间要一个空行。
对于每组测试数据保证它有且只有一个解。
 

Sample Input
  
  
7 1 2 ? 6 ? 3 5 8 ? 6 5 2 ? 7 1 ? 4 ? ? 8 5 1 3 6 7 2 9 2 4 ? 5 6 ? 3 7 5 ? 6 ? ? ? 2 4 1 1 ? 3 7 2 ? 9 ? 5 ? ? 1 9 7 5 4 8 6 6 ? 7 8 3 ? 5 1 9 8 5 9 ? 4 ? ? 2 3
 

Sample Output
  
  
7 1 2 4 6 9 3 5 8 3 6 5 2 8 7 1 9 4 4 9 8 5 1 3 6 7 2 9 2 4 1 5 6 8 3 7 5 7 6 3 9 8 2 4 1 1 8 3 7 2 4 9 6 5 2 3 1 9 7 5 4 8 6 6 4 7 8 3 2 5 1 9 8 5 9 6 4 1 7 2 3




//思路:dfs,从上到下,从左到右每次检查一个可以填的点(chess[i][j]==0),然后依次枚举k(1~9),判断合法性,如果合法,就再接着搜索


AC源码:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define LOCAL

int store[9][9],chess[9][9],flag=1;
bool isValid(int x,int y,int k)
{
	for(int i=0;i<9;++i)
		if(i!=x&&chess[i][y]==k)
			return false;
	for(int j=0;j<9;++j)
		if(j!=y&&chess[x][j]==k)
			return false;
	int newx=x/3*3;
	int newy=y/3*3;
	for(int i=newx;i<newx+3;++i)
	{
		for(int j=newy;j<newy+3;++j)
		{
			if(i==x&&j==y)
				continue;
			if(chess[i][j]==k)
				return false;
		}
	}
	return true;
}

bool shudu()
{
	for(int i=0;i<9;++i)
	{
		for(int j=0;j<9;++j)
		{
			if(chess[i][j]!=0)
				continue;
			for(int k=1;k<=9;++k)
			{
				chess[i][j]=k;
				if(isValid(i,j,k)&&shudu())
				{
					if(flag)
					{
					//	memcpy(&store[0][0],&chess[0][0],sizeof(chess));
						memcpy(store,chess,sizeof(chess));
						flag=0;
					}
					return true;
				}
				chess[i][j]=0;
			}
			return false;
		}
	}
	return true;
}

int main()
{
#ifdef LOCAL	
	freopen("data.in","r",stdin);
	freopen("data.out","w",stdout);
#endif
	int kase=0;
	char x;
	while(cin>>x)
	{
		int fg=1;
		for(int i=0;i<9;++i)
		{
			for(int j=0;j<9;++j)
			{
				if(fg)
				{
					fg=0;
					if(x=='?')
						chess[i][j]=0;
					else
						chess[i][j]=x-'0';
				}
				else
				{
					cin>>x;
					if(x=='?')
						chess[i][j]=0;
					else
						chess[i][j]=x-'0';
				}
			}
		}
		shudu();
		flag=1;
		if(kase++)
			cout<<endl;
		for(int i=0;i<9;++i)
		{
			for(int j=0;j<9;++j)
			{
				if(j==0)
					cout<<store[i][j];
				else
					cout<<" "<<store[i][j];
			}
			cout<<endl;
		}
	}
	return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值