hdu Problem-4004(二分)

本文介绍了一道经典的算法竞赛题目——铁蛙三项中的跳跃挑战。任务是在限定次数内跨越河流,利用最少的最大跳跃距离完成任务。文章提供了完整的AC源码,并详细解释了二分搜索与模拟验证的解题策略。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

The Frog's Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 7263    Accepted Submission(s): 3482


Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m. 
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

Output
For each case, output a integer standing for the frog's ability at least they should have.
 

Sample Input
  
  
6 1 2 2 25 3 3 11 2 18
 

Sample Output
  
  
4 11



//思路:题目的的意思是求,在m次内通过河可以选择的最短跳跃距离,用二分枚举0~L内的数

重点在如何判断选择的数是否合法,其实简单模拟一下就行了(详见代码judge函数)

//其中我TLEL了几次,分别是不能while(cin>>L>>n>>m) for(k=0;k<50;++k)(修改详见代码)

AC源码:

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;

const int MAXN=500000+10;
int L,n,m,dis[MAXN];
bool judge(int mid,int m,int num)
{
	int sum=0,i=0;
	while(m--)
	{
		sum+=mid;
		while(sum>=dis[i])
		{
			++i;
			if(i==num)
				break;
		}
		i=i-1;
		sum=dis[i];
	}
	if(sum>=L)
		return true;
	else
		return false;
}

int main()
{
	while(scanf("%d %d %d",&L,&n,&m)!=EOF)
	{
		dis[0]=0;
		dis[1]=L;
		int i=2;
		while(n--)
			cin>>dis[i++];
		sort(dis,dis+i);
		int a=0,b=L;
		for(int k=0;k<20;++k)
		{
			int mid=a+(b-a)/2;
			if(judge(mid,m,i))
				b=mid;
			else
				a=mid;
		}
		printf("%d\n",b);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值