Coin-collecting by robot

本文探讨了机器人进行硬币收集的问题,详细分析了输入、输出及其样例,揭示了背后的算法逻辑。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Coin-collecting by robot
1000(ms)
65535(kb)
738 / 2013
Several coins are placed in cells of an n×m board. A robot, located in the upper left cell of the board, needs to collect as many of the coins as possible and bring them to the bottom right cell. On each step, the robot can move either one cell to the right or one cell down from its current location
输入
The fist line is n,m, which 1< = n,m <= 1000.
Then, have n row and m col, which has a coin in cell, the cell number is 1, otherwise is 0.
输出
The max number Coin-collecting by robot.
样例输入
5 6
0 0 0 0 1 0 
0 1 0 1 0 0 
0 0 0 1 0 1 
0 0 1 0 0 1 
1 0 0 0 1 0
样例输出
5

#include<iostream> 
#include<stdio.h> 
#include<malloc.h>
#include<string.h>
#include<string>
#include<stack>
#include<math.h>
#include<algorithm>
using namespace std;
#define INF 99999999

int a[1005][1005];

int main() {
	int m,n;
	cin>>m>>n;
	for(int i=1;i<=m;i++){
		for(int j=1;j<=n;j++){
			cin>>a[i][j];
		}
	}
	for(int i=1;i<=m;i++){
		for(int j=1;j<=n;j++){
			if(a[i-1][j]>a[i][j-1])
				a[i][j]+=a[i-1][j];
			else
				a[i][j]+=a[i][j-1];
		}
	}
	cout<<a[m][n]<<endl;
 	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值